Forums

Home Forums Troubleshooting Access denied through Wireguard server (permission denied)?

Access denied through Wireguard server (permission denied)?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5670
    Daarke01
    Participant

    I’m trying to connect to my device through VPN server when I’m away from home remotley. I have tried all 3 options (OpenVPN, IKEv2 and Wireguard), but I get some sort of permission denied on all.

    If we take Wireguard for example, I’ve followed these instructions: https://www.pcwrt.com/2021/01/the-complete-guide-to-setting-up-a-wireguard-vpn-server-at-home-with-pcwrt/. Problem is, while I’m connected to the Wireguard wg0 and try accessing ‘192.168.10.1’ or ‘ssh [email protected].1’ in the cmd I get the following:

    “ssh: connect to host 192.168.10.1 port 22: Permission denied”

    Is there something wrong about the firewall settings? I have tried on two different PC’s with same result. I have also tried checking both boxes “Network Acess -> [X]LAN [X] Internet” but that doesn’t do any difference either.

    • This topic was modified 1 year, 2 months ago by Daarke01.
    • This topic was modified 1 year, 2 months ago by Daarke01.
    • This topic was modified 1 year, 2 months ago by Daarke01.
    #5674
    Daarke01
    Participant

    The router is connected directly to wall/WAN, not behind any other router.
    And [X]Enable mDNS have been selected in Settings->Security, still I get permission denied.

    • This reply was modified 1 year, 2 months ago by Daarke01.
    #5677
    support
    Keymaster

    Can you successfully “ping” 192.168.10.1?

    #5678
    Daarke01
    Participant

    I was wrong, after connecting to the wg0 interface the ip is no longer “192.168.10.1” but the new ip-adress that is listed in Apps-Wireguard-Server XXX.XXX.XXX.0
    I can now access my router. However I am still unable to connect over adb to one of my devices unless I’m at the same network.
    Calling “adb connect xxxxxx:5555” generates “An attempt was made to access a socket in a way forbidden by its access permissions. (10013)”

    But the first problem is solved.

    • This reply was modified 1 year, 2 months ago by Daarke01.
    • This reply was modified 1 year, 2 months ago by Daarke01.
    • This reply was modified 1 year, 2 months ago by Daarke01.
    • This reply was modified 1 year, 2 months ago by Daarke01.
    #5683
    Daarke01
    Participant

    I can’t ping my phone that’s connected on wifi while I’m on Wireguard remote vpn server. Thought I would gain access to it by connecting to the server vpn, because I can connect to my router. I’d only get a “General failure” in the cmd.

    • This reply was modified 1 year, 2 months ago by Daarke01.
    #5685
    Daarke01
    Participant

    Is there a way to be able to ping 192.168.10.106 when I’m connected to the Wireguard server? It only works without even though I have checked [X]LAN access in Wireguard->Server settings?

    #5686
    Daarke01
    Participant

    Solution: Need to ssh to the router before pinging LAN devices. Thought I could just enter Wireguard then ping directly.

    #5687
    support
    Keymaster

    Since LAN is checked in server configuration, you should be able to ping other devices on LAN directly. Can you check the routing tables on your VPN client?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.