Forums

Home Forums Feature Suggestions Add settings "Network modes" to stop wifi dropping

Add settings "Network modes" to stop wifi dropping

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5265
    Daarke01
    Participant

    My Linksys router suffers from occasional wifi drops. I’ve set the MTU to a proper value (using ping service + 28) but it still happens every now and then. There are a couple of links and youtube videos explaining a possible solution to this, which is (in Linksys routers at least) to change Network mode from “Mixed” which is set default —> “802.11a/n Only”. I’ve seen a couple more people having same problem here, and I think this solution might help more people who is also experiencing random crashes.

    #5266
    Daarke01
    Participant

    This problem was not present on my TP-Link Archer C7 router. And given that there are videos on youtube with a lot of comments of people saying it worked for them instantly after changing this setting. It’s safe to say that this will help those of us who is having the Linksys WRT1900ACS router with the same issue.
    Either make the option available, or make “802.11a/n Only” the new default when installing the nre firmware.

    • This reply was modified 1 year, 11 months ago by Daarke01.
    • This reply was modified 1 year, 11 months ago by Daarke01.
    #5269
    Daarke01
    Participant

    Looked in SSH /etc/config in wireless and realized:

    For config wifi-device ‘radio0 and ‘radio1’

    1) option country_code (default FR), i have now changed to my own country_code.

    2) option require_mode is missing.

    I’ve added option require_mode ‘ac’

    I’m gonna test a while and see if this helps with the stability.

    • This reply was modified 1 year, 11 months ago by Daarke01.
    #5271
    support
    Keymaster

    @daarke01 By “wifi drops” did you mean your device got kicked off of the wifi? Or was wifi still connected but no Internet?

    #5273
    Daarke01
    Participant

    I’m loosing wifi entirely(kicked), for about 10 seconds then it reconnects.
    I’ve had similar problems with different router brands before, never had this problem at home with my previous D-link.

    As I suspect, with Linksys WRT1900ACS it does not like when the mode is not specified (i’m on a windows 10 laptop).
    Right now, I’ve updated the settings in my /etc/config/wireless file accordingly.
    So far, I haven’t had another wifi dropping today. But I’ll uppdate when its been a week to be sure. So far looking good.

    config wifi-device ‘radio0’
    option type ‘mac80211′
    option hwmode ’11a’
    option path ‘soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0’
    option disabled ‘0’
    option country ‘SE’
    option txpower ’20’
    option htmode ‘VHT40’
    option require_mode ‘ac’
    option legacy_rates ‘0’
    option channel ’36’

    config wifi-device ‘radio1’
    option type ‘mac80211′
    option hwmode ’11g’
    option path ‘soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0’
    option htmode ‘HT20’
    option disabled ‘0’
    option country ‘SE’
    option txpower ’20’
    option channel ‘6’
    option require_mode ‘n’
    option legacy_rates ‘0’

    • This reply was modified 1 year, 10 months ago by Daarke01.
    • This reply was modified 1 year, 10 months ago by Daarke01.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.