Forums

Home Forums Troubleshooting Adding Fitbit Aria Scale (Model 1)

Adding Fitbit Aria Scale (Model 1)

This topic contains 9 replies, has 2 voices, and was last updated by  support 2 weeks, 2 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5380

    trust_in_wrt
    Participant

    Hello,

    I’ve been having troubles connecting the Fitbit Aria (weight scale) to my wifi network. It used to connect to my previous router, but not the Newifi D2. I’m using the guest wifi network on the Newifi D2. The scale requires 2.4GHz 802.11b which I see is supported on the Newifi, as listed here: https://shop.pcwrt.com/products/pcwrt-newifi-d2-dual-band-secure-wifi-router. Below are my relevant settings. Do you have any advice on what to change? Also, is there a place where I can see a log of attempts to log into the wifi network?

    Thanks

    
    Settings/Network
    
    - Software flow offloading: not checked
    - stealth mode: not checked
    - block ping: checked
    - block DNS rebind attack: checked
    - enable mDNS: not checked
    
      VLAN
    
          D e s t i n a t i o n
        _________________________
    S   |       |  LAN  | Guest |
    o   _________________________
    u   |  LAN  |  Yes  |  Yes  |
    r   _________________________
    c   | Guest |       |  Yes  |
    e   _________________________
    
    Settings/Wireless/2.4GHz/Device
    
    - Stop KRACK: Not Checked
    - Channel: Auto
    - Width: 20 MHz
    - Power: 100%
    - Use same MAC filter for all bands: checked
    - MAC address Filter: disabled 
    
    Settings/Wireless/2.4GHz/WifiNetworks/GuestX
    
    - Disable SSID broadcast: Not checked
    - Enable Wifi client isolation: Not checked
    - Encryption: WPA2-PSK
    - Cipher: CCMP (AES)
    
    • This topic was modified 2 weeks, 6 days ago by  trust_in_wrt. Reason: formatting code section
    #5382

    support
    Keymaster

    Did you use a computer to set up the scale? Was the computer connected to the same guest network on the 2.4GHz band?

    #5383

    trust_in_wrt
    Participant

    Yes, I tried configuring the wifi connection from different wireless devices including an iPhone and a Windows 11 laptop. Both were on the Newifi’s guest wifi network. Then Fitbit’s config software sets up a captive wifi portal on the scale, so I have to connect to that. Then I pick the desired Newifi’s guest wifi network and enter the password manually.

    Is there a record of wifi login attempts and errors? That may help us.

    #5384

    support
    Keymaster

    You’ll need to ssh into the router. Enter “logread -f” into the ssh session, then connect your Aria again. The “logread -f” command will print new log lines when a device tries to connect to the router.

    For a successful connection, you’ll see lines like these:

    Fri Jul 17 06:34:19 2020 kern.warn kernel: [ 4289.255394] ASSOC - Assign AID=1 to 2.4GHz AP 8c:70:5a:00:01:02
    Fri Jul 17 06:34:19 2020 kern.warn kernel: [ 4289.261522] ASSOC - HT support STA. Update AP OperaionMode=2, fAnyStationIsLegacy=0, fAnyStation20Only=1, fAnyStationNonGF=1
    Fri Jul 17 06:34:25 2020 daemon.info dnsmasq-dhcp[21721]: DHCPDISCOVER(br-lan) 192.168.101.229 8c:70:5a:00:01:02
    Fri Jul 17 06:34:25 2020 daemon.info dnsmasq-dhcp[21721]: DHCPOFFER(br-lan) 192.168.10.229 8c:70:5a:00:01:02

    If Wifi connection is not successful, you won’t see the DHCP lines.

    #5385

    trust_in_wrt
    Participant

    Thanks for your continued assistance. Fitbit Support asked me to use numbered channels for my 2.4 and 5.0 GHz bands so I set them as follows:

    Changed 2.4 GHz settings:
    – Channel: from ‘Auto’ to ‘1 (2.412 GHz)’
    – Width: 20 MHz (no change)

    Changed 5.0 GHz settings:
    – Channel: from ‘Auto’ to ‘149…’
    – Width: from 20 to 80 MHz

    Once I connected to the router with SSH, I started “logread -f”. Below is the log when attempting to configure the Fitbit device. (Note that in the logs, I manually redacted the first 4 pairs of what appears to be a MAC address.)

    On iPhone, I picked the Fitbit device’s captive portal wifi network.

    
    Thu Jun 16 11:56:29 2022 kern.warn kernel: [2059644.719197] 2.4GHz AP ASSOC - receive DIS-ASSOC(seq-1550) request from [redacted]:ef:d9, reason=8
    

    On iPhone, I picked the Newifi Guest wifi network, and entered password.

    
    Thu Jun 16 12:00:26 2022 kern.warn kernel: [2059881.622034] ASSOC - Assign AID=11 to 2.4GHz AP [redacted]:ef:d9
    Thu Jun 16 12:00:26 2022 kern.warn kernel: [2059881.628341] ASSOC - HT support STA. Update AP OperaionMode=3, fAnyStationIsLegacy=0, fAnyStation20Only=1, fAnyStationNonGF=1
    Thu Jun 16 12:00:26 2022 daemon.info dnsmasq-dhcp[791]: DHCPREQUEST(br-guest) 10.159.157.55 [redacted]:ef:d9
    Thu Jun 16 12:00:26 2022 daemon.info dnsmasq-dhcp[791]: DHCPACK(br-guest) 10.159.157.55 [redacted]:ef:d9
    

    Any thoughts or observations?

    Also, Fitbit Support wants me to send them a screen-shot of the router config page showing where the 802.11b protocol is explicitly enabled at 2.4 GHz. Is there a Newifi config screen or terminal command that will provide this?

    #5386

    support
    Keymaster

    By the log, the router assigned IP address 10.159.157.55 to the Aria. You should be able to see it listed under the “Connected Devices” section on the Status page. Unless “[redacted]:ef:d9” was your iPhone?

    The 2.4GHz band operates in b/g/n mixed mode, so there’s no need to specifically enable b mode.

    #5387

    trust_in_wrt
    Participant

    Thanks, but to clarify, the Fitbit device did not connect. The device still gave a “Wifi Err” message. I scanned the wifi spectrum using NetSpot and it reported that Newifi guest wifi network was operating in Channel 1 of the 2.4 GHz band with Mode ‘n’. My understanding is that 802.11n routers accept 802.11b connections and I provided this info to Fitbit Support, but their devices don’t seem to work that way. Here is their response:

    …confirm that your network allows the option ‘b’. We’d like one screenshot of your settings showing the protocol/option ‘b’. ..the Aria scale syncs with protocol ‘b’ only. It won’t connect otherwise. If your router/network allows the options ‘n’ or other such as ‘g’ etc, the scale won’t connect…

    Is there any page in the router settings where I can take a screenshot showing Fitbit Support that 802.11b is set? If not, is there a setting/command that I can enable only 802.11b on my guest wifi network? (I’m willing to run an iwconfig command, or similar, on the router via SSH. If necessary, I could run the command again after any router firmware updates.)

    Thanks again.

    #5388

    support
    Keymaster

    The WiFi mode setting affects all WiFi networks associated with the band. E.g., if you set it to 11b only, then both LAN and guest will have 11b. The default setting for 2.4GHz is b/g/n mixed.

    You can change the setting in “/etc/config/wireless”. In the example below, wifimode is set to ‘1’, which is “11b only”.

    config wifi-device 'ra0'
            option type 'mt7603e'
            option vendor 'ralink'
            option band '2.4G'
            option wifimode '1'

    Other options are:

    • 0: 11b/g mixed
    • 3: 11a/b/g mixed
    • 5: 11a/b/g/n mixed
    • 9: 11b/g/n mixed (default setting)
    #5389

    trust_in_wrt
    Participant

    Thank you for this guidance. I modified the /etc/config/wireless file and rebooted the router.

    Now the Netspot app confirms that the router’s 2.4GHz band is running in only 802.11b mode.

    The scale is connecting perfectly. 😊 😊 😊

    In future, after firmware updates, will my custom setting survive or will I need to update the /etc/config/wireless file again?

    #5390

    support
    Keymaster

    @trust_in_wrt Your custom settings will survive an upgrade. But of you reset the router to factory defaults, then you need to update the config file again.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.