Forums

Home Forums General Configuration Authenticating Proxy

Authenticating Proxy

This topic contains 4 replies, has 3 voices, and was last updated by  support 2 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #367

    PeterD
    Participant

    Hi,
    What needs to be done to use authenticating proxies? I checked the appropriate box in Parental Controls, created users with profiles, and associated devices with those profiles.

    I expected that at some point (periodic? how often?) when one of the devices listed in the profile made a request to port 80 (http) the router would intercede and ask for a user id and password. I expected that would happen at port 8080, since that’s the default on the pcWRT page. But nothing happens. Do I have to reboot the router to get authentication working?

    #368

    support
    Participant

    @peterd You’ll need to set up your browser to use the proxy server on port 8080. For example, if you are using Chrome: https://www.google.com/search?q=set+proxy+in+chrome.

    Please note that you don’t have to use the authenticating proxy for parental control. When you assign a device to a profile, the device is controlled by the profile (for all users using the device).

    However, you can use the authenticating proxy server to elevate privileges for a user (or users) on a controlled device. For example, if you share a PC with a child, you can assign the PC to a limited profile. When you use the PC, you’ll be limited by the same profile. But you can set up a proxy user to go beyond the limits of that profile. And this is how you do it:

    1. Enable the authenticating proxy server
    2. Create a proxy user
    3. Assign the proxy user to an unlimited profile
    4. Configure your browser to use the authenticating proxy via browser settings (or preferences)
    5. When browsing, authenticate to the proxy server using the credentials created in step 2.
    #369

    PeterD
    Participant

    Thanks for the thorough reply!

    #1477

    imjhoskins
    Participant

    Would I use my gateway as the HOST and Port specified (8080 default)? Not working for me.

    #1480

    support
    Participant

    @imjhoskins Can you give more details? I.e., parameters used in your setup and what was happening?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.