Forums

Home Forums Troubleshooting Can't log into luci

Can't log into luci

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  support 1 year, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3181

    BashDashovi
    Participant

    I just upgraded to the Gigabit dual band router and everything is working great except I’m not able to log in using luci. 192.168.10.1/cgi-bin/luci and I get a log in prompt, but after entering the password, the log in screen just loads again. I can log into the PCWRT interface just fine with the same password.

    Has luci been disabled in the latest build or do I need to set a password for luci separately?

    #3183

    support
    Participant

    Luci has been removed in the latest update. Do you have any specific needs for Luci?

    #3218

    BashDashovi
    Participant

    I find it easier to do some advanced settings than adding firewall rules via uci commands. My network is a little non-standard in that my router and a few other machines are behind a cable modem, and most of the rest of the devices are behind the router. So I needed to poke a hole through the firewall to allow access to the WAN. I realize most people wouldn’t need to do this and there are other ways to make the changes, but I prefer LUCI.

    #3226

    support
    Participant

    @bashdashovi When you say poke a hole for WAN access, do you mean port forwarding?

    #3327

    BashDashovi
    Participant

    I’m not sure if what I did qualifies as port forwarding, I’m allowing tcp on port 80 from the WAN so that I can configure the router from its WAN (all still in my home’s LAN).

    Here are the commands I ran after sshing in:

    (NOTE: For those who come across this: DO NOT DO THIS UNLESS YOU REALLY KNOW WHAT YOU ARE DOING! This creates a huge security hole in most circumstances!)
    uci add firewall rule
    uci set [email protected][-1].src=wan
    uci set [email protected][-1].target=ACCEPT
    uci set [email protected][-1].proto=tcp
    uci set [email protected][-1].dest_port=80
    uci commit firewall
    /etc/init.d/firewall restart

    • This reply was modified 1 year, 8 months ago by  BashDashovi.
    #3339

    support
    Participant

    You can set this up by creating a port forwarding rule on the Network Settings page. Select the router for Internal Address.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.