Forums

Home Forums General Configuration Can't upgrade

Can't upgrade

This topic contains 10 replies, has 2 voices, and was last updated by  support 3 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2477

    nman4ever
    Participant

    Hi,

    running an older version v1.22.4.

    When clicking upgrade in system, pops up a webpage with only the following text

    “{“status”:”success”,”upgrade_status”:{“status”:”upgrade”,”release_notes”:”http:\/\/www.pcwrt.com\/forums\/topic\/pcwrt-firmware-v1-27-release-notes\/”,”version”:”v1.27″},”message”:””}”

    but no upgrade.

    same thing happens when i try to sync time.

    sync time with browser: says “{“status”:”success”,”apply”:”system”}” but time doesn’t update. wondering if its something with this older version it won’t do the upgrade?

    #2478

    support
    Participant

    @nman4ever You might want to clear your browser cache and try again.

    #2479

    nman4ever
    Participant

    i’ve tried on
    chrome
    safari (cleared cache)
    firefox (fresh install).

    same thing. seems to pop up json object but doesn’t interact with the device.

    #2480

    nman4ever
    Participant

    tried from android phone as well. (another system). same thing.

    #2484

    support
    Participant

    @nman4ever It looks JavaScript failed on the page. That’s why I asked you to clear browser cache. And if that’s the case, you’d have trouble in other pages too, such as saving parental control settings.

    With either Firefox or Chrome, you can hit F12 to bring up the “Developer Tools” dialog. Click the Console tab. Do you see any errors there?

    #2485

    nman4ever
    Participant

    Uncaught TypeError: Cannot read property ‘length’ of undefined
    at Function.each (jquery.min-0ebb125a54a3.js:2)
    at HTMLDocument.<anonymous> (system-0ebb125a54a3.js:1)
    at j (jquery.min-0ebb125a54a3.js:2)
    at Object.fireWith [as resolveWith] (jquery.min-0ebb125a54a3.js:2)
    at Function.ready (jquery.min-0ebb125a54a3.js:2)
    at HTMLDocument.I (jquery.min-0ebb125a54a3.js:2)

    #2486

    support
    Participant

    @nman4ever Do you see this error on other pages besides System?

    #2487

    nman4ever
    Participant

    only on the system page.

    #2493

    support
    Participant

    @nman4ever Please send a screenshot of the System page and “Developer Tools” console tab to [email protected]. Thanks!

    #2499

    nman4ever
    Participant

    Thank you to Support team for helping me solve the issue. For anyone else with this problem here is the fix.

    Its a bug with at least up to 1.27.1. developer said they will fix in future.

    supposedly nature of bug is if you don’t have ntp servers listed, show up with these javascript errors in developer console of chrome.

    Fix is factory reset, then reconfigure device. upon the factory reset and turning everything back on. Everything else works as intended. Except after upgrading from 1.24 -> 1.27, no longer can get into router from wan side https. not sure why. Everything else worked including upgrading and syncing time with browser now. 😉

    #2503

    support
    Participant

    @nman4ever The bug is fixed in v1.27.1.

    You may need to reconfigure Cloud Settings in order to be able to manage the router from the Internet again.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.