Forums

Home Forums Device Setup (printers, IP phones etc.) Exclude VOIP from VPN

Exclude VOIP from VPN

Tagged: , ,

This topic contains 10 replies, has 2 voices, and was last updated by  prurtz8 1 year ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #4254

    prurtz8
    Participant

    My voice over internet phone does not work if my pcwrt router has VPN enabled. Is there a way to exclude the phone from the VPN?

    #4255

    support
    Participant

    Is your VoIP phone connected by wire? If so, go to the Network Settings page to create a dedicated VLAN for the phone. I.e., put the port you’re connecting the phone to under a different network name. Reboot the VoIP phone after you do that.

    #4259

    prurtz8
    Participant

    I created a VLAN for my phone X1. It is in the port next to the LAN port, so I used VLAN port #1. I set up my VPN and checked LAN but left X1 unchecked. I unplugged and then plugged in my phone again. Still, it will not register.

    #4260

    support
    Participant

    Try rebooting your phone (power off, the power on). Also, login to the router, check the IP address of your phone, should be in the X1 network.

    #4261

    prurtz8
    Participant

    How do I know what the IP address of the X1 vlan is? My phone is still not working with this router.

    #4262

    support
    Participant

    IP address for the X1 network should be 10.159.158.x.

    #4263

    prurtz8
    Participant

    No, it doesn’t work. Maybe vlan is only for WiFi. I have disabled WiFi and only use a hardwired connection.

    #4264

    support
    Participant

    VLAN works for wired connections too. Does your phone still have an IP address in the LAN range? Is it getting an IP address via DHCP?

    Also, you should connect to the left most port, which is port number 1. I.e., when you look at the back of the router, the port numbers are 1, 2, 3, 4, from left to right.

    #4268

    prurtz8
    Participant

    When I try to use vlan on my hardwired connection, the router will not provide internet access to my computer. I have to restore a backup for internet access to be restored. One of the reasons I bought this router was because I could install VPN on it and exclude some items from the VPN.

    #4270

    support
    Participant

    @prurtz8 The concurrent VPN/non-VPN setup has been fully tested and works well (for both wired and wireless configurations). Please provide more detailed information to us so that we can help you to resolve this problem.

    Please send the following to [email protected]:

    1. Screenshot of the Network Settings page showing VLAN port assignments
    2. Which port is your PC connected to. And a screenshot of the output of the command “ipconfig”
    3. A screenshot of the Status page
    4. Screenshots of the VPN client pages for OpenVPN, IKEv2 and WireGuard
    #4273

    prurtz8
    Participant

    Here’s the fix from pcwrt support:

    If you look at the ethernet ports, they are labels etched out below them (but very hard to see). When the ethernet ports are facing you, the left-most port is “Lan 4” and each number decreases down to “Lan 1” right next to the WAN port. Plug your VOIP in the left-most (when the ports are facing you) lan port. labeled “Lan 4.”

    Log into the pcwrt router and navigate to Settings / Network. Choose the X1 VLAN on VLAN port 1.

    Go th “Apps” and create your VPN connection. Under “Enable for Network” you should see two checkboxes, one labeled “LAN” and one labeled “X1.” Check the box for “LAN” but leave the box for X1 unchecked.

    You should be able to start your VPN now and have your VOIP still work (if it does not work on VPN like mine doesn’t).

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.