Forums

Home Forums Parental Control Google stops working when Parental Controls are enabled

Google stops working when Parental Controls are enabled

This topic contains 19 replies, has 2 voices, and was last updated by  support 5 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #706

    stringer
    Participant

    I just installed the router and updated firmware to 1.21. When I turn on Parental Controls, I am not able to visit www.google.com or perform any google searches on my laptop. Bing works fine. I’ve toggled just about every option I can think of. I tried clearing the DNS cache (on OS X 10.11.5), restarting the browser (tried Safari and Chrome), and rebooting the laptop (late 2013 MBP). Nothing seems to work. When I turn off Parental Controls, google works fine. I am able to get to gmail when parental controls are enabled. I’ve tried listing google.com in the white list. Didn’t work. As an aside, on my iPhone, google works fine even with Parental Controls enabled.

    #707

    support
    Participant

    What is the error? Did you get the “Site Blocked” page or the “Connection not private”/”Attacker might be trying to steal your information” error?

    #708

    stringer
    Participant

    Here’s a screen grab of the error:
    Error Msg

    (“The requested URL is blocked on this network.
    http://www.google.com:443“)

    • This reply was modified 5 years, 3 months ago by  stringer.
    #710

    support
    Participant

    Do you have another parental control product running on the laptop?

    Also, with parental control enabled, can you run these two commands from a command window and share the output?
    1. nslookup www.google.com
    2. ping www.google.com

    #711

    stringer
    Participant

    I do have Covenant Eyes running on my laptop.

    nslookup produced the following result:

    ScottsLaptop:~ Scott$ nslookup www.google.com
    Server: 192.168.10.1
    Address: 192.168.10.1#53

    Non-authoritative answer:
    www.google.com canonical name = forcesafesearch.google.com.
    Name: forcesafesearch.google.com
    Address: 216.239.38.120

    ping produced the following result:

    ScottsLaptop:~ Scott$ ping www.google.com
    PING www.google.com (216.239.32.20): 56 data bytes
    64 bytes from 216.239.32.20: icmp_seq=0 ttl=53 time=35.676 ms
    64 bytes from 216.239.32.20: icmp_seq=1 ttl=53 time=16.463 ms
    64 bytes from 216.239.32.20: icmp_seq=2 ttl=53 time=18.524 ms
    64 bytes from 216.239.32.20: icmp_seq=3 ttl=53 time=14.238 ms
    […. several other lines ….]
    64 bytes from 216.239.32.20: icmp_seq=76 ttl=53 time=13.554 ms
    64 bytes from 216.239.32.20: icmp_seq=77 ttl=53 time=14.907 ms
    ^C
    — www.google.com ping statistics —
    78 packets transmitted, 78 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 11.933/27.036/495.013/59.158 ms

    #712

    support
    Participant

    There’s a conflict between Covenant Eyes and the pcWRT router with Google SafeSearch.

    You can try add this line to the Hosts box in the System Settings page, just under the “localhost” line:
    216.239.32.20 forcesafesearch.google.com

    #713

    stringer
    Participant

    Thanks. I figured it was a conflict. Layered filtering systems tend to not play well together. I tried the host name, but it didn’t help. I’ve also turned off the SafeSearch option in the Parental Controls pane, but that doesn’t seem to make a difference, either. The only way I’ve been able to get google search to work is to disable all Parental Controls, which essentially makes this router useless (or no better than any other router anyway) for me. I’m hoping to find a solution, otherwise, I’ll need to return the router. Thanks for the continuing support. I’ve also contacted Covenant Eyes, but they’re not familiar with your router nor have they had any previous reports of conflicts.

    #714

    stringer
    Participant

    One question the CovEyes tech asked was whether the router could exclude executable files. He was oriented toward the windows OS, though, and couldn’t identify the applicable executable for CovEyes on a Mac. From my own looking around, it looks like it would be:
    /Applications/Covenant Eyes.app/Contents/MacOS/Covenant Eyes

    He also mentioned that the Mac domains are:
    mac.ces.cvnt.net and api.cvnt.net

    Not sure if that’s helpful.

    #715

    support
    Participant

    After you update the hosts file, try the ping and nslookup commands again. They should show the same IP address: 216.239.32.20. Right now, one is 216.239.32.20, and the other is 216.239.38.120. That’s the problem.

    The host change will take a couple of minutes to take effect. If you still see a discrepancy, you might want to flush the DNS cache again on the laptop. Let us know how it worked.

    #716

    stringer
    Participant

    Re-ran nslookup and ping:

    ScottsLaptop:~ Scott$ nslookup www.google.com
    Server:		192.168.10.1
    Address:	192.168.10.1#53
    
    Non-authoritative answer:
    Name:	www.google.com
    Address: 198.52.15.215
    Name:	www.google.com
    Address: 198.52.15.230
    Name:	www.google.com
    Address: 198.52.15.226
    Name:	www.google.com
    Address: 198.52.15.219
    Name:	www.google.com
    Address: 198.52.15.207
    Name:	www.google.com
    Address: 198.52.15.222
    Name:	www.google.com
    Address: 198.52.15.241
    Name:	www.google.com
    Address: 198.52.15.236
    Name:	www.google.com
    Address: 198.52.15.249
    Name:	www.google.com
    Address: 198.52.15.234
    Name:	www.google.com
    Address: 198.52.15.237
    Name:	www.google.com
    Address: 198.52.15.221
    Name:	www.google.com
    Address: 198.52.15.251
    Name:	www.google.com
    Address: 198.52.15.211
    Name:	www.google.com
    Address: 198.52.15.245
    
    ScottsLaptop:~ Scott$ ping www.google.com
    PING www.google.com (216.239.32.20): 56 data bytes
    64 bytes from 216.239.32.20: icmp_seq=0 ttl=53 time=16.421 ms
    64 bytes from 216.239.32.20: icmp_seq=1 ttl=53 time=14.211 ms
    64 bytes from 216.239.32.20: icmp_seq=2 ttl=53 time=14.148 ms
    64 bytes from 216.239.32.20: icmp_seq=3 ttl=53 time=15.839 ms
    64 bytes from 216.239.32.20: icmp_seq=4 ttl=53 time=20.862 ms
    64 bytes from 216.239.32.20: icmp_seq=5 ttl=53 time=13.230 ms
    ^C
    --- www.google.com ping statistics ---
    6 packets transmitted, 6 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 13.230/15.785/20.862/2.512 ms

    Also ran sudo killall -HUP mDNSResponder to reset the DNS cache. Google is now working. I reset the cache when I first had this problem, and that fixed google for a little bit, but then it stopped working again after cycling Parental Controls. After cycling Parental Controls, re-ran nslookup and ping again:

    ScottsLaptop:~ Scott$ nslookup www.google.com
    Server:		192.168.10.1
    Address:	192.168.10.1#53
    
    Non-authoritative answer:
    Name:	www.google.com
    Address: 198.52.15.236
    Name:	www.google.com
    Address: 198.52.15.226
    Name:	www.google.com
    Address: 198.52.15.241
    Name:	www.google.com
    Address: 198.52.15.215
    Name:	www.google.com
    Address: 198.52.15.207
    Name:	www.google.com
    Address: 198.52.15.237
    Name:	www.google.com
    Address: 198.52.15.211
    Name:	www.google.com
    Address: 198.52.15.219
    Name:	www.google.com
    Address: 198.52.15.249
    Name:	www.google.com
    Address: 198.52.15.222
    Name:	www.google.com
    Address: 198.52.15.245
    Name:	www.google.com
    Address: 198.52.15.251
    Name:	www.google.com
    Address: 198.52.15.221
    Name:	www.google.com
    Address: 198.52.15.234
    Name:	www.google.com
    Address: 198.52.15.230
    
    ScottsLaptop:~ Scott$ ping www.google.com
    PING www.google.com (216.239.32.20): 56 data bytes
    64 bytes from 216.239.32.20: icmp_seq=0 ttl=53 time=13.653 ms
    64 bytes from 216.239.32.20: icmp_seq=1 ttl=53 time=15.773 ms
    64 bytes from 216.239.32.20: icmp_seq=2 ttl=53 time=16.307 ms
    64 bytes from 216.239.32.20: icmp_seq=3 ttl=53 time=18.937 ms
    64 bytes from 216.239.32.20: icmp_seq=4 ttl=53 time=16.303 ms
    64 bytes from 216.239.32.20: icmp_seq=5 ttl=53 time=13.874 ms
    64 bytes from 216.239.32.20: icmp_seq=6 ttl=53 time=22.618 ms
    ^C
    --- www.google.com ping statistics ---
    7 packets transmitted, 7 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 13.653/16.781/22.618/2.889 ms
    #717

    support
    Participant

    Is Safe Search unchecked on the router?

    #718

    stringer
    Participant

    And sure enough, after cycling Parental Controls off then on, google no longer works again. I have to wipe the DNS cache to restore google access every time Parental Controls is turned on.

    #719

    stringer
    Participant

    Yes, safe search is unchecked.

    #720

    support
    Participant

    Safe Search should be checked in order for the router to be consistent with CovEyes. And both nslookup and ping should return same IP address.

    #721

    support
    Participant

    Yes, if you turn parental control on and off consecutively, the DNS records on the laptop will be out of sync with that on the router. Therefore, the need to clear the DNS cache each time. However, the DNS caching time is only 5 seconds, so 5 seconds after you turn parental control on or off, if you restart the browser, you should be OK. BTW, is there a need to turn parental control on/off for the laptop regularly? If so, you might want to uncheck “Block proxy, VPN, TOR”.

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.