Home Forums General Configuration How to set up OpenDNS

How to set up OpenDNS


Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #144

    As described in our blog post, as a home user, you can use OpenDNS in two ways: OpenDNS Family Shield or OpenDNS Home. The former does not need a login to OpenDNS, while the latter requires you to set up a free account with OpenDNS.

    If you decided to use OpenDNS Family Shield, it takes a single step to use OpenDNS in pcWRT: just select “OpenDNS Family Shield” in the DNS Server dropdown in a profile under Parental Control Settings.
    OpenDNS Family Shield

    If you want to use OpenDNS Home, there are five steps:

    1. Sign up for an account at OpenDNS.
    2. Set Dynamic IP Update for OpenDNS.
      • login to OpenDNS
      • click the Settings tab
      • Select your home network in the Settings for dropdown
      • Click Advanced Settings
      • Check Dynamic IP Update
        OpenDNS Dynamic IP
    3. Log in to with the same OpenDNS username and password. Add the OpenDNS service.
    4. Log in to pcWRT router management console, click Dynamic DNS, select from the Service dropdown, then enter your OpenDNS username and password. Click Save.
      pcWRT Dynamic DNS
    5. In pcWRT Parental Control settings, select OpenDNS Home from the DNS Servers dropdown.
      pcWRT OpenDNS Home
    • This topic was modified 8 years, 6 months ago by pcwrt.

    So, what if the Dynamic DNS setup page keeps throwing the following error: Failed to update Dynamic DNS, please check your network connection.

    I have quadruple checked the username and password being entered. I’m copying/pasting. I’ve tried both my username and my email address that I registered with OpenDNS to setup my account. None of them works.

    The PCWRT router IS connected to the internet and when I enter “” into my browser, the following is the result:

    What now?


    As a side note, if I enter that IP address into my browser (, the browser never gets anywhere. Says this:

    This site can’t be reached took too long to respond.


    Actually, never mind. Wasn’t paying attention to what that IP represented. It’s me, so the browser likely wouldn’t “go” anywhere.


    If you enter this into your browser, what do you get?


    Replace [USERNAME], [PASSWORD] and [IP] with real values. But please don’t post the values here, just the response from dnsomatic.

    • This reply was modified 7 years, 8 months ago by pcwrt.

    I’m asked to login again.

    An “auth” popup comes up.


    Sorry, the URL should be: https://[USERNAME]:[PASSWORD]<IP Address>, i.e., https instead of http. Either one works, but https provides more security.

    An auth dialog means USERNAME & PASSWORD provided are not authenticated by dnsomatic. USERNAME is usually your email address registered with OpenDNS.

    You might also want to check the WAN ip address on the pcWRT router. Open the Status page on pcWRT router management UI. Does the WAN ip match the IP address you got from dnsomatic?


    Do you still have problems? In fact, if the username or password is wrong in your DDNS configuration, the error message should be ‘Failed to update Dynamic DNS, please check your username and password and try again.’.

    What’s the Internet IP address as seen on the Status page? What are the DNS 1 and DNS2 values on the same page?


    There is no WAN IP or DNS 1 & 2 on my status page. This is what’s there:

    Type: dhcp
    Connected: 9h 32m 14s
    SSID: pcwrt
    Mode: Master
    Channel: 6 (2.437 GHz)
    Encryption: WPA2-PSK

    Connected Devices
    Hostname IP Address MAC Address Network Signal
    Dads-Business-Laptop DC:53:60:16:44:05 Master “pcwrt” -77 dBm


    Thanks for the info. That’s a strange problem. Please send us a copy of your configuration, we’ll investigate further. Here’s how:
    1. Login router management console.
    2. Click System in the Settings page.
    3. In the Backup/Restore Settings section, click the Backup button.
    4. Save the file and send to [email protected].

    Sorry for the problems and thanks for your patience!


    Sending my backup file to you as I type this.



    I have the same problem. It has to do either with the password length or the characters in the password. OpenDNS allows a wide range of special characters and up to 256 character password length. The only way I could get this to work was by reducing the password length in OpenDNS and reducing the special characters. As a note, I use Keepass2 for my password generation. A 256-bit password with special characters, upper, lower, and numbers will create this issue.

    Looking forward to a bug fix! Thanks!


    @SafeTay Thanks for your feedback. Our tests showed that dnsomatic fails authentication when the password contains either the apostrophe (‘) or the quote (“). In that case, the router reports “Failed to update Dynamic DNS, please check your network connection.”, which is a wrong message. We’ll fix the error message in a future update. We’ll also see if there’s a way to report the error to dnsomatic. It’s worth noting that the authentication bug does not exist in dnsomatic web interface, only the update API.

    We’ll also follow up with a long password test. Thanks for your input!


    I’m having the same problem. Can I email you my backup info too?


    @corinnacs Yes, please.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.