Forums

Home Forums General Configuration Netflix streaming issues

Netflix streaming issues

This topic contains 15 replies, has 6 voices, and was last updated by  smarttvhelpline 3 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #430

    docnific
    Participant

    I set up the router and all devices are working great, however when I try to stream Netflix I receive an error (“content is unavailable, try again later) for all of Netflix titles. This is happening with my Roku and Kindle. Amazon titles seem to stream fine so it appears that this is happening with Netflix only. I was (and still am) able to stream Netflix using the unprotected router that was provided by the ISP. Any ideas?

    #431

    support
    Participant

    @docnific Netflix uses IP addresses (instead of domain names) directly to get streaming media. So if you uncheck “Block literal IP addresses” in parental control, it’ll work. This is usually OK, unless you find that kids are trying to circumvent parental control by typing IP addresses directly into the browser. Then you have to “Block literal IP addresses”, but allow Netflix in another way. It’s doable, but will require more effort on your part.

    #464

    raffy
    Participant

    I’m having trouble with Netfix streaming, too. It’s on a smarttv connected wirelessly, and on a profile with parental controls disabled. Please help.

    #465

    support
    Participant

    @raffy You should have no trouble with Netflix in such a configuration. Did you correctly identify the SmartTV device?

    In order to troubleshoot, you can try these steps:
    1. Disable parental control entirely by clicking the Disable button of the Parental Control page. Are you able to watch Netflix?
    2. If above is yes, turn parental control back on. Is Netflix blocked now? If yes, are you blocked from the whole site or only when you try to stream a video?
    3. If Netflix is blocked in step 2, disable parental control in all profiles (uncheck “Enable Parental Control” in each profile). Are you able to watch Netflix now?

    #466

    raffy
    Participant

    I will try that tonight. Please note, however, that I am not blocked from Netflix. It just freezes up and stops every few minutes. Same thing on Amazon and YouTube. Streaming worked perfectly on this TV prior to installing new router. TV is on a separate profile with no parental controls.

    #469

    support
    Participant

    @raffy What you are seeing seems to be slow network speed – the TV is buffering before it can continue to play. The suggestions I made before are not relevant.

    First thing to check is to see if you have a strong enough wifi signal for the TV: log in the router and click Status, check the value in the Signal column. Should not be less than -80dBm.

    If wifi signal strength is good, you might want to try switching wifi to a different channel (in Settings/Wireless).

    You might also want to try comparing Netflix playback on a PC vs. on the TV.

    #470

    raffy
    Participant

    It’s around -60dBm. I’ll try switching channels. Video playback is fine on my tablet in the same room.

    #471

    raffy
    Participant

    It was on channel 7. I changed it to channel 9. Is there any particular channel that should work better?

    #472

    support
    Participant

    @raffy Wifi signal is strong enough. The reason I suggest that you try changing channels is that sometimes there are electronic interferences from other nearby wifi signals. In such cases, even though the wifi signal is strong, the transmission speed remains low due to the interference. If by changing channels you don’t see any effect, we can rule out the interference factor. Since it was originally on 7, you might want to try something like 1 or 11.

    Just to help further debugging this issue, what model and year is your SmartTV? Does it have a built-in wifi adapter or a plugin type such as a USB stick? If plugin, what is the model?

    #473

    raffy
    Participant

    I changed to channel 9, and the performance has improved substantially. Only froze up once or twice tonight. 2012 Samsung with built-in adapter. I’ll experiment further and get back with you.

    #474

    raffy
    Participant

    Amazon Prime and YouTube are working fine now as well. Thanks a bunch for the excellent support!

    #901

    Dan
    Participant

    @support

    Any further clues or links on the “doable, but will require more effort” method of blocking literal IPs AND still accessing Netflix?

    #903

    support
    Participant

    @Dan As it turned out, Netflix no longer request video streams by literal IP addresses. So blocking literal IP addresses will no longer block Netflix. And, if you want to set up a calendar for Netflix, take a look at this: How to set a calendar on Netflix.

    #910

    Dan
    Participant

    @support

    Hmmm… toggling the literal IP option still seems to block and unblock Netflix for me, I am using Australian Netflix though.
    (AU Netflix is sadly significantly different from US despite the fact it is still Netflix, perhaps they are slow in implementing the new US Netflix method?)

    Any thoughts on this?

    I’d love to try the “doable, but will require more effort” method if you think it could be worth trying?

    • This reply was modified 5 years, 1 month ago by  Dan.
    #913

    pcwrt
    Keymaster

    @Dan Here’s how to do it:
    1. Open Netflix in a browser (Chrome or Firefox will do).
    2. Press the F12 key. A developer toolbox will display.
    3. Click the Network tab.
    4. Start streaming with Netflix. You’ll see the requested URLs in the developer popup.
    5. Notice the URLs for video streams, those will probably be requested via IP addresses directly.
    6. Collect the IP addresses used.
    7. For each IP address, add a line in the Hosts box in the System Settings page, e.g., 54.214.39.210 netflix.com

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.