Forums

Home Forums General Configuration pcwrt and D-Link Router. HELP!

pcwrt and D-Link Router. HELP!

This topic contains 6 replies, has 2 voices, and was last updated by  Casino 3 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1900

    Casino
    Participant

    I’m getting crazy! I need help.

    I’m from Italy and i can’t connect pcwrt to my D-Link DSL 2750B router.

    pcwrt only works in wireless mode but not in my home pc through the LAN. Everytime i insert 192.168.10.1 or http://pcwrt nothing compare. It’s impossible suft the internet on my home pc.

    I connected fist LAN port of the router to the WAN port of pcwrt. Then i connected LAN port of the home pc to the LAN port of pcwrt.

    I have to modify something in “Internet Configuration”? Or in “Network Configuration”?
    I have to modify something in my D-Link Router? In my home pc, for using file sharing programs, i setted a static ip (192.168.1.2)

    Please, help!

    Here it is an image of the back of my D-Link router
    D-Link Back

    Here it is a screenshot of my Static IP:
    Static IP

    P.S. Sorry for my english!

    • This topic was modified 3 years, 7 months ago by  Casino.
    #1902

    support
    Participant

    You need to select the first option in TCP/IP properties, i.e., automatic assignment of IP addresses. Your PC will then get an IP address in the 192.168.10.x range. Internet will work.

    Then go to the pcWRT management console, find your PC in the Status page Connected Devices section, click on the hostname link and click Save on the popup dialog. After that, your PC will get the same IP address from the router every time. You can use the new IP address for your shares.

    #1904

    Casino
    Participant

    But, after this, can i set a static ip again like that in the image above?

    And, have i connected the cable right? LAN Router – WAN pcwrt / LAN Home PC – LAN pcwrt?

    Thanks.

    #1905

    support
    Participant

    Your connection is correct. But you don’t need to assign a static IP on the PC. After you do the above, the pcWRT router will assign a static IP to the PC (with the PC side selecting automatic IP address assignment). When you look at the PC on the Status page, the host name for the PC should be displayed in blue instead of gray.

    #1906

    Casino
    Participant

    Thank you, but, for my personal preferences, I HAVE TO assign a static ip on the PC.

    What can i do?

    Anyway, i have another problem. I can’t set automatic IP address assignment for some reasons, so, is it possible surf in internet on my home pc (LAN) without touch my home pc preferences and just modify in pcwrt settings? I don’t know, maybe in internet configuration (PPoe etc…) or network configurtation etc…

    #1909

    support
    Participant

    If your PC has to have the IP address 192.168.1.2 with subnet 255.255.255.0, then you need to change the IP address of the pcWRT router to 192.168.1.1, instead of the default 192.168.10.1. You can to this on the Network Settings page.

    At the same time, you need to change the IP address of your D-LINK router to something other than 192.168.1.1. For example, you can change it to 192.168.2.1 (i.e., to any subnet other than 192.168.1.x).

    #1916

    Casino
    Participant

    Thank you so much. But, after you’ve changed the D-Link Gateway address, you NEED to reboot pcwrt router for update it at the new settings of the D-Link Router

    1) Change D-Link Gateway Address

    2) Reboot pcwrt

    3) Change IP address of the pcwrt

    Now, internet works through the LAN, finally!

    Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.