Forums

Home Forums General Configuration pcWRT and Fastweb

pcWRT and Fastweb

This topic contains 14 replies, has 2 voices, and was last updated by  support 1 year, 3 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3744

    Casino
    Participant

    I have completally changed my home line. I have a FTTC with Fastweb:

    https://www.fastweb.it/

    Internet works, but not if i set my TP-Link in Bridge Mode. My tp-link is called “Archer VR1200v”

    https://www.tp-link.com/it/home-networking/dsl-modem-router/archer-vr1200v/#overview

    I tried to select in pcwrt Internet Connection “DHCP Client” but internet doesn’t work. I can’t put PPPoE or PPPoA because Fastweb doesn’t accept them.

    I seen that my ISP can work in Bridge Mode with the “IPoE (Dynamic IP) but i can’t find it in the Internet Setting of the pcwrt.

    https://en.wikipedia.org/wiki/IPoE

    Can you help me?

    #3753

    support
    Participant

    Looks like in this case you need to use DHCP on the pcWRT. This post says that you need to bridge all interfaces on your modem:

    VDSL Modem in Bridge Mode: How does it work?

    #3756

    Casino
    Participant

    Found the solution. DHCP in the internet setting of the pcwrt, and, absolutely, to disable DHCP server on the TP-Link.

    Delete all the connections in the TP-Link, create a new connection in Bridge Mode with the VLAN ID given by your ISP.

    #3757

    Casino
    Participant

    Problem not solved, VoIP doesn’t work anymore. With the TP-Link in Bridge Mode internet is perfect, the phone not.

    I need to set it in the pcWRT. Can you help me?

    • This reply was modified 1 year, 4 months ago by  Casino.
    #3759

    support
    Participant

    @casino What’s your VoIP equipment? How is it connected to your network?

    #3760

    Casino
    Participant

    What do you mean with “VoIP equipment?

    This is my phone:

    https://www.gigaset.com/it_it/gigaset-c570-system-it/

    and i have attached it to the “Phone” port behind my modem

    Everything is perfect, but when i switch to the bridge mode the phone doesn’t work anymore. From what i’m reading in internet, there’s need a “Phone” port behind the pcWRT….

    • This reply was modified 1 year, 4 months ago by  Casino.
    #3762

    Casino
    Participant

    Here you can read my phone configuration with the TP-Link:

    https://www.tp-link.com/it/support/faq/2367/

    #3763

    Casino
    Participant

    As you can see, my gigaset has a analog connection mode only, it’s not a native VoIP, but without the bridge mode, the VoIP works perfectly.

    #3765

    Casino
    Participant

    From the official page of my ISP:

    https://www.fastweb.it/adsl-fibra-ottica/dettagli/altri-modem/

    3. Requirements and settings related to VoIP service

    SIP support (RFC 3261)
    DNS query support for address resolution of Fastweb SIP network access proxy
    SIP proxy: voip.fastwebnet.it
    Proxy SIP Port: 5060
    SIP Transport Protocol: UDP
    Support for the PRACK method (RFC 3262)
    Support OPTIONS method
    REGISTER expires time: 3600 s
    INVITE Expires: set to a value greater than 430 s
    Supported codecs: G.729 G.729A (including version A, versions B and AB NOT supported), G.711 A-law
    VAD (Voice Activity Detection): disabled
    Packetization time: 20ms
    DTMF tone support: in-band telephone-event (RFC 2833)
    Fax protocol: only T.38
    IP traffic QoS marking:
    SIP and RTP: DSCP CS5
    Data: DSCP 0

    #3774

    Casino
    Participant

    More than 10 days have passed, and the story is very, very long. This story ends with a question, pcWRT support SIP ALG?

    #3776

    support
    Participant

    @casino I thought you resolved this problem. Your IP phone must be connected to the TP-Link.

    If you have restored the TP-Link to router mode and put the pcWRT in the DMZ, then IP phone should be working when connected to the TP-Link.

    #3778

    Casino
    Participant

    The problem has been solved with this:
    http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht802

    in this way i can have the TP-Link in Bridge Mode too.

    The configuration was very, very difficult, I had to contact the Grandstream official support and 3 other telecommunications experts to make it works.

    After the configuration it worked with the tp-link, but not with the pcWRT. pcWRT does not have ALG functionality.

    The ONLY way to make it works with the pcwrt was through the STUN server, but not all ATA support it. So you need to buy an ATA that support it.

    So, at the end, pcWRT does not support SIP ALG, or it doesn’t manage it very well?

    • This reply was modified 1 year, 4 months ago by  Casino.
    #3780

    support
    Participant

    pcWRT does not support SIP ALG.

    #3820

    Casino
    Participant

    In your opinion, will pcwrt ever support ALG? pcWRT and VoIP are enemies.

    #3821

    support
    Participant

    It’s not in the plan. Many VoIP products work fine without ALG.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.