Forums

Home Forums Announcements pcWRT firmware v2.4.1 Release Notes

pcWRT firmware v2.4.1 Release Notes

This topic contains 8 replies, has 4 voices, and was last updated by  knoxploration 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4577

    support
    Participant

    Changes included in this update (v2.4.1):

    • Add split tunneling capability to VPN clients. Now you can enter a list of destination domain names or IP ranges to exclude from the VPN connection. Or the reverse: use the VPN connection only for the specified domain names or IP ranges. The regular expression syntax for Access Control lists also work in this area.
    • Minor bug fixes.

    Upgrade steps:

    1. Have your configuration backup ready. Create a backup of your current configuration file, if you don’t have one.
    2. Click the “Check for Updates” button in the System Settings page. Follow the instructions to upgrade.
    3. After successful upgrade, create a new router settings backup file from the System Settings page and save it in a safe place.
    #4595

    BashDashovi
    Participant

    I’m having the weirdest issue with this update. Every morning since updating, all Amazon echos in my house report that they are not connected to the internet, while other devices have no issue. Rebooting or moving a device from one profile to another and hitting save restores their connectivity. Any idea how to debug this?

    #4596

    support
    Participant

    @bashdashovi Is Ad blocking enabled on the profile? If so, check the Internet logs for which domains required by Echo was blocked as Ad. Post those domains here and we’ll remove those from the ad blocking list.

    As an immediate test, you can create a separate profile for the Echo devices and disable Ad blocking for the profile.

    #4601

    BashDashovi
    Participant

    No ad blocking on any profile. This morning the one Echo I moved to a new profile was still connected to the internet but the others that remained on the Default profile all claimed to be disconnected. I didn’t find any blocked sites for any of them in the logs over the previous 12 hours. Once again, moving one device from one profile to another and hitting save connected all devices. The default profile has Access Control enforced and safe search and is using OpenDNS Family Shield for DNS.

    #4602

    support
    Participant

    @bashdashovi You may try putting all Echo devices in a dedicated profile and selecting a non-filtering DNS such as 1.1.1.1.

    #4603

    BashDashovi
    Participant

    It turns out that the issue is not limited to Echos. All devices that are on profiles with calendars will not have internet access once their time is back. For example, I have a laptop on a profile that stops access at 10pm and restores it at 6am. At 8:30am, the laptop still does not have any internet access. It is listed as connected to the router in Status, but nothing shows up in the Access logs, blocked or otherwise, after the internet should have come back on for it. I DO see blocked requests during the calendar outage period with the blocked reason “Calendar”.

    It looks like once the calendar time starts for a profile, the router instead stops honoring any requests from devices on that profile.

    #4607

    support
    Participant

    @bashdashovi There’s probably something else then. We didn’t have any problems with calendars keep blocking when they’re supposed to be back on. The last update did not touch the Access Control functions either.

    Can you send a copy of your backup file to [email protected]?

    #4765

    Barry_dudley777
    Participant

    How long does the update take? Mine says the upgrade file is corrupted, but then it looks like it’s flashing the update to the device anyways, but it never seems to finish the flash upgrade. Is it possible to download the flash upgrade for the firmware and do a manual upgrade?

    #4778

    knoxploration
    Participant

    Ever since this update, managing through the pcwrt.com website stops working for me after an indeterminate period of time. I get a notice that the router isn’t available, although it is currently online. Rebooting the router fixes the problem. Anyone else experiencing this? I never saw it prior to the last update but have seen it several times in the past few weeks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.