Forums

Home Forums Parental Control questions on Block proxy, VPN, TOR

questions on Block proxy, VPN, TOR

This topic contains 9 replies, has 2 voices, and was last updated by  support 4 years, 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1345

    skydogtookmycash
    Participant

    When I check the box for Block proxy, VPN, TOR, it prevents a kids game called Roblox from working (one of the kids likes this game). I put www.roblox.com into the Allowed URL list and have Black List box checked, but still didn’t work. So then experimented with www.opendns.com/welcome. I find that it too doesn’t work when the Block proxy, VPN, TOR box is checked, but does work when unchecked. I put www.opendns.com/welcome into the Allowed list and still doesn’t work. I don’t think it matters, but FYI this PC is behind a OOMA VOIP phone adaptor, thus the profile is assigned to the OOMA phone adaptor (in case anyone other than pcwrt support team is reading this, I learned from support today that the OOMA box does NAT on the home port, thus the IP for the PC is assigned by the OOMA box and therefore the PC is invisible to the router). I assume it doesn’t matter, but Block literal IP addresses is not checked.

    Any ideas of what to try next, other than just giving up and unchecking the box? (although to be honest I don’t really know what this feature really does or how important it is) ?

    #1346

    support
    Participant

    @skydogtookmycash The checkbox is used to block attempts to bypass parental control with VPN, proxy server, TOR, etc. Once a device gets on a VPN (for example), the router only knows that a connection is made out to the VPN server, but any web site can be visited by tunneling through the VPN (therefore, defeating parental control).

    However, when that checkbox is checked, games such as Roblox may be blocked because the router cannot distinguish communications to a game server and communications to a VPN server. Servers may be white listed to avoid such blocking, but that technique does not work for Roblox. Because for Roblox the server IP addresses are dynamic and it seems not possible to get an exhaustive list. The only option for now is to leave it unchecked.

    That said, the checkbox can be safely left unchecked when children are young and don’t have the technology knowhow. Or you don’t give children administrative rights on the PC so that they cannot install VPN on it.

    BTW, visits to http://www.opendns.com/welcome should not be blocked either way. In case it is blocked when the box checked, you can close the browser and reopen it and the problem should go away.

    #1347

    skydogtookmycash
    Participant

    I’m learning new things every day. This issue with Roblox leaves me wondering how many other popular games are the same way, where the server IP addresses are dynamic, combined with the fact that the router can’t distinguish between communications to VPN server vs communications game server as you mentioned.

    Back to the issue of www.opendns.com/welcome not showing up as working in the browser, I’m seeing things that I don’t understand. For example, for one of the PC’s that I previously had on the unprotected profile, and had never previously attempted www.opendns.com/welcome thus not in cache, I went ahead and moved to protected profile with OpenDNS Family Shield, with Block proxy, VPN, TOR unchecked, and tried www.opendns.com/welcome test. It still didn’t indicated it was working. But then I did tried “internetbadguys.com” (as suggested on OpenDNS website), and it did seem to block it as a phishing threat. So I guess OpenDNS was working despite the fact that www.opendns.com/welcome test was not working.

    By the way, just to try it out I created an OpenDNS Home account, to see how the logging works. Despite your clear directions, because I’m not so skilled in this stuff I still struggled some with one of the steps, but I finally got through it. Maybe for those of us that need spoon fed through this process, you could add one more little step to your blog instructions, that helps explain how to get from initially clicking “Settings” to the option for Advanced Settings. What I mean is, when I first selected Settings, it did not yet bring up Advanced Settings as a choice. There was another small step in between that was confusing to me that perhaps you could address in future updates to instructions. Thanks!

    #1348

    support
    Participant

    What do you mean by http://www.opendns.com/welcome test not working? Are you seeing the page that displays:

    Oops…
    You aren’t using OpenDNS yet.
    Let’s fix that.

    #1349

    skydogtookmycash
    Participant

    Yes, that is the screen I’m referring to, when attempting the welcome test.

    Something else I forgot to ask… When I first opened the OpenDNS Home account, there was a step in the process where it looked like I was supposed to download software onto my pc. I never did though. I think it was called OpenDNS Updater. Is that a necessary step to take advantage of OpenDNS Home, if using the pcWRT router?

    By the way, I’m finding that I really like the ability to use remote access. I just use the chrome browser on my android phone. The menus don’t take long to load and seem to display just fine.

    #1350

    skydogtookmycash
    Participant

    Let me add that I’m finding that having the Block proxy, VPN, TOR box checked is also preventing the OOMA phone adaptor from working properly. Basically it seems to go offline (although the PC connected to its home port is still online, but without Roblox working). Is that expected? Is there a fix for that, other than unchecking the box?

    #1351

    support
    Participant

    The OpenDNS welcome page problem seems strange. Can you add your Android phone to the same profile and see if there is a difference?

    No, you don’t need the OpenDNS Updater. That’s what the Dynamic DNS settings on the router is for.

    Yes, checking the block proxy etc. box will block OOMA. As it currently stands, you have to leave it unchecked .

    #1352

    skydogtookmycash
    Participant

    Added Android phone to profile, same thing happens. I get the Oops screen, but when I click on the internetbadguys link it successfully treats it as a phishing threat. I tried it first with OpenDNS Home, then tried again with Family Shield, same result. Note that at one time the .welcome test was working properly. Probably coincidence, but it was only after I started trying OpenDNS Home that I started getting the Oops screen on a protected profile instead of the success screen.

    #1353

    skydogtookmycash
    Participant

    I figured out why this happened, and let me apologize in advance for not thinking of it before. At about the same time I was trying OpenDNS Home for the first time, I was also experimenting with the use of Blocked URLs, Allowed URLs, Black List and White List to see how they work. Well….for some stupid reason I had inserted “www.openDNS.com” into Allowed URLs, and forgot about removing it. I just removed it, and now I get the normal response from the welcome test. I believe the mystery is solved. I hope you didn’t rack your brain too hard on this one.

    #1354

    support
    Participant

    Great you figured it out! It didn’t come to me that white listing opendns.com would mess up the OpenDNS test page. Now we know!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.