Forums

Home Forums General Configuration Samba port forward wan->lan

Samba port forward wan->lan

This topic contains 17 replies, has 2 voices, and was last updated by  mizarcs 5 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #628

    mizarcs
    Participant

    Hi all, I received your router and it’s great! The parental control is really easy to configure and works perfectly.
    I only need a suggestion on how to configure the portFW because I have a NAS in the “old” net (192.168.1.0/24) with a samba share. I try to configure the FW but it seams I’m doing something wrong and there is no way to access my shared disk. I can ping it but nothing else. Can you tell me what I have to setup inside the router? My configuration is 192.168.10/0 pcWRT router connected on a ADSL router 192.168.1.0/24 via wan plug and the NSF is 192.168.1.6 static.
    I’d like to let all devices connected on the pcWRT (lan and/or Wi-Fi) to “see” the NFS 192.168.1.6.
    Can you help me?
    TIA

    #633

    support
    Participant

    Thanks for contracting us. It seems that our filters are a bit too aggressive in this situation. Please allow us a few days to correct this. We’ll update this thread once this is fixed. Thanks!

    #646

    support
    Participant

    @mizarcs Please upgrade to v1.20.4 and see if you can access the Samba shares via \\192.168.1.6.

    #649

    mizarcs
    Participant

    I can’t … neither connect to my share nor browse any other external site like Google or incredibly your one!
    Also white-list doesn’t work and the tragedy is that I cant roll back to the previous version that doesn’t let me connect to my share but let me navigate ….
    Is there a new problem on the new firmware or is it mine?
    Let me know …

    #650

    support
    Participant

    So you can’t browse the Internet at all, right? There’s no change in this build that would block your Internet access. Let’s figure out the problem before worrying about shares etc.

    Can you access the router management page? I.e., http://pcwrt/ or http://192.168.10.1, assuming that you didn’t change the LAN address?

    If so, turn parental control off, try to browse Google. Are you able to?

    #651

    mizarcs
    Participant

    SO …. yes I can browse the management console and I have disabled parental control; as I can see I can now navigate (without filter of course).
    If I re-enable parental control I receive an invalid Google’s certificate that can’t be verified and If I continue (Safari) the router tells me that “The requested URL is blocked on this network. http://www.google.com:443“.
    Any suggestion is welcome.

    #652

    support
    Participant

    The Google cert error and the blocked message means your browser is blocked by the parental control filter. Do you know which profile the device belongs to? In that profile, is “URL Filter Mode” set to “White List”? If so, please switch to “Black List” and try again.

    #653

    mizarcs
    Participant

    I didn’t set up a profile: I’d like to “filter” the Wi-Fi completely so I activated the parental control and left the default flags (adding youtube restricted mode). The URL filter mode is on Black list as default, and the DNS Server is OpenDNS Family Shield.
    Adding in “Allowed URL’s” yours and the Google.it one doesn’t change anything at all.
    Using also a Linux machine so I can test with a pc and answering with the other one.
    Is there any other test I can do for you? Simply ask c]:-)

    • This reply was modified 5 years, 4 months ago by  mizarcs.
    #655

    support
    Participant

    Then there’s no need to add Google or pcwrt.com to the white list. In “Black List” filter mode, you only need to enter domains to the Allowed URLs list when it is blocked by OpenDNS.

    Can you try to flush the DNS cache on your PC or MAC? If you don’t know how to do this right off the top of your head, rebooting the PC does the same trick.

    #656

    mizarcs
    Participant

    ok flushed on Ubuntu and I can now browse google.it and your site. Parental control is enabled. Can a dirty DNS cache create such problems?
    New lesson learned ….
    So next step is how to let the share work. Let me check and I tell you the result.
    Thanks a lot for now.

    #657

    mizarcs
    Participant

    Not what I was expecting …. “Unhandled error message: Failed to mount Windows share: Connection timed out”. Ubuntu 14.04.02 (I know it’s old) via Wi-Fi
    Now it’s up to you again … c]:-D

    #658

    support
    Participant

    The router blocks efforts to circumvent DNS check. Cached DNS looks the same as someone using a hosts file to bypass DNS.

    #659

    support
    Participant

    You can run the same tests: disable parental control and see if you can access the share. If yes, does turning on parental control block your access? If no, can you check that the TCP ports 139 and 445 are open? E.g., ‘telnet 192.168.1.6 445’ can open connection successfully?

    #660

    mizarcs
    Participant

    Ok I’ll check tomorrow Morning.it’s midnight …
    Thanks and have a good WE

    #661

    mizarcs
    Participant

    Parental control enabled: no samba share connections due timeout.
    Configuration: client Wi-Fi ip 192.168.10.150
    Network: all defaults settings but: Port FW
    Name protocol Ext. Port Internal add. Internal Port
    Samba1 TCP UDP 139 192.168.10.150 139
    Samba2 TCP udp 138 192.168.10.150 138
    Samba3 TCP UDP 137 192.168.10.150 137
    Samba4 UDP 445 192.168.10.150 445
    Telnet on both ports (139 445) successful
    Parental control disabled: successfully connected to my share on 192.168.1.6
    Question: do I have to use the specific IP or can I use a generic one? the share should be accessible to all the net 192.168.10.x the router propose me the router itself: is it correct?

    • This reply was modified 5 years, 4 months ago by  mizarcs.
Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.