Forums

Home Forums Troubleshooting WAN IP Address Change

WAN IP Address Change

This topic contains 8 replies, has 2 voices, and was last updated by  Casino 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2864

    Casino
    Participant

    My WAN IP Address change. Sometimes it’s 192.168.2.4, other times 192.168.2.2 etc….

    I have to put it in the DMZ of my D-Link router and i need that this number doesn’t change.

    #2868

    support
    Participant

    Two options:

    1. Configure your D-Link to assign a static IP address to the pcWRT (consult your D-Link manual)

    2. Select “Static” for Internet connection from the pcWRT management console. For example, enter 192.168.2.2 for IP address, 255.255.255.0 for netmask, 192.168.2.1 for gateway, 1.1.1.1 for DNS. To avoid IP address conflicts, exclude 192.168.2.2 from the DHCP pool on the D-Link. Again, consult D-Link manual on how to change the DHCP range on the D-Link.

    #2870

    Casino
    Participant

    1) Look here:

    this is all about DHCP, but i don’t have idea how to avoid specific ip address from DHCP, maybe “DHCP reservation”?

    2) I’ve tried to set Static IP Address in the Internet Setting of the pcwrt, but pcwrt goes in crash. The message “Applying Changes” is infinite and i need to reset the router.

    I have as Router IP Addresses:

    1) D-Link = 192.168.2.1

    2) pcwrt = 192.168.1.1

    So, in internet setting i’ve put 192.168.1.2 for IP Address, 255.255.255.0 for subnet mask and 192.168.1.1 for gateway. It’s all right?

    #2871

    support
    Participant

    It’s probably easiest to add a DHCP reservation to your D-Link router. In the ADD/EDIT DHCP RESERVATION section, enter:

    Computer Name: pcWRT
    The IP Address: 192.168.2.2
    MAC Address: copy the MAC address from the pcWRT Internet Settings page “Override MAC address” field

    Click Apply.

    Select “DHCP client” for pcWRT Internet Settings protocol.

    #2872

    Casino
    Participant

    And if i want to do this:

    I have as Router IP Addresses:

    1) D-Link = 192.168.2.1

    2) pcwrt = 192.168.1.1

    So, in internet setting i’ve put 192.168.1.2 for IP Address, 255.255.255.0 for subnet mask and 192.168.1.1 for gateway. It’s all right?

    What i have to do? Is this setting correct?

    • This reply was modified 9 months, 2 weeks ago by  Casino.
    #2875

    support
    Participant

    @casino That is not correct. If your D-Link LAN address is: 192.168.2.1, and your pcWRT LAN address is: 192.168.1.1, then on the Internet page for the pcWRT, you should have 192.168.2.2 for IP address and 192.168.2.1 for gateway.

    #2877

    Casino
    Participant

    Thank you. I have these settings on my home pc:

    I have to change them?

    • This reply was modified 9 months, 1 week ago by  Casino.
    #2879

    support
    Participant

    @casino That’ll work if you connect your PC to the pcWRT. It’ll fail if you connect your PC to the D-Link. It’s better to leave your PC on DHCP, i.e., select “Obtain an IP address automatically”.

    #2882

    Casino
    Participant

    Ok, i’ve tested it for three days.

    With Static IP Address and Bridge Mode, internet doesn’t work good. It works good just with DHCP Client in Internet Setting.

    With your knowledge, why this happen? And especially, why this happen only when my modem is connected to the pcwrt? And why, internet works good with DHCP and not when it’s setted on Bridge Mode and Static IP?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.