Forums

Home Forums General Configuration How to remote control the pcWRT router

How to remote control the pcWRT router

This topic contains 19 replies, has 5 voices, and was last updated by  support 2 weeks, 2 days ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1293

    support
    Participant

    Follow the steps below to enable remote control. You have to be connected to the pcWRT router at home to do this.

    1. Log in to the pcWRT router management console.
    2. Click Settings at the top right corner, then click Cloud.
    3. Enter your username and the “remote management key” for www.pcwrt.com. If you don’t have one, click the register link to create an account. You need to copy the “remote management key” from the Manage page on www.pcwrt.com.
    4. Check the Enable Remote Management box, enter a name for your router, then click Save.

    Enable remote control

    After remote control is enabled, you can manage the router remotely by logging on pcwrt.com and click the Manage link.

    Remote manage

    If you connected the pcWRT router behind another router (i.e., it doesn’t have a public IP address), then there are a couple of extra steps:

    1. Enter a number between 1024 and 65535 for Bind Port. Then click Save.
    2. Configure your main router to port forward UDP for the port number you chose above to the pcWRT router.
    #1435

    Max
    Participant

    I find myself locked out of my router. The password that worked yesterday won’t work today. When I try to reset the password, it allows me to log into my account, but I don’t have access to my router through it and don’t know how to establish it. Help!

    #1436

    Max
    Participant

    Hey, I managed to reset the router and change the password. I think I need to spend some time learning the system to better manage my router.

    #1437

    support
    Participant

    Good to know that you figured it out! If you enabled remote control, then there are two ways to access the management pages: locally with your local router password, or remotely with your pcwrt.com username/password. These passwords work independently, i.e., changing one does not change the other. But whenever you change the pcwrt.com password, you need to sync up the remote control credentials locally in order to keep remote control functional.

    #1439

    Max
    Participant

    I’m having a lot of trouble with access and functionality right now. I changed the password to http://pcwrt/cgi-bin/pcwrt/login yesterday; I found that I could not connect to the network with the new passwords; now I’m shut out again and can’t access. When I did have access briefly, I noticed that I didn’t have a “cloud” option under settings to access the router remotely. Also, I could not use the DNS settings. The whole system seems pretty unreliable, probably because I’m doing something wrong or have set something up wrong. Is there a way to clear all the old passwords, update the firmware and just start from scratch? Otherwise, I don’t think I can keep using this–it may be a bit too complicated for me.

    #1440

    Max
    Participant

    Sorry, it’s the MAC filter that I can’t get to work. So I just reset the router and was prompted to reset my router access password and the network password, which I did. I’d like to set things up so that I can use the MAC filtering to enable some devices but not others. When I tried this, I was able to save the changes. But I was unable to connect with a device that I had set up to have access–my new password was denied. Right now, I’m left to just disabling the wifi altogether to regulate it–but I’d like to get the full system to work again so I can regulate device by device without any difficulty. Any advice?

    #1441

    Max
    Participant

    When switching the wifi network to enabled from disabled, however, I’m getting an “incorrect password” error when I try to connect. . .

    #1442

    Max
    Participant

    But it did work with an old password that is somehow being retained by the system . . . I’m very confused!

    #1443

    support
    Participant

    There are two types of passwords for the router:
    1. The WiFi password
    2. The router management password.

    The WiFi password is the “key” field in the WiFi security section. You distribute this key to your WiFi users so that hey can connect to the WiFi. The router management password is used to log in the router management console so that you can change settings, set up parental control etc.

    Apparently, the WiFi password should be different from the router management password, since you don’t want your WiFi users to be able to manage the router. You should keep your router management password a secret.

    Then, there is remote control. You don’t need to enable it in order to manage the router. But if you do enable it, this offers you a second way to manage the router, by logging in pcwrt.com with your pcwrt.com user name and password. However, the Cloud settings can only be changed when you are connected locally (and logged in with the local router password). This is because, when you are remote managing the router, you need cloud management enabled, and you cannot disable remote management while using remote management.

    Please bear in mind that while there are multiple ways to manage the router, you don’t have to use all functions simultaneously. You can start from the simpler options and progress toward more complex ones. These options are provided so that if you need them, they are available. But you don’t have to use them until there’s a need.

    This is one path you could take:

    1. In the simplest form, the router is functional after you perform the initial setup. For basic parental control, simply select “OpenDNS Family Shield” for DNS in the parental control page and Save.
    2. If you need MAC address filtering, you can add them after the above setup. Though we want to mention that MAC address filtering does not add much to WiFi security. And for access control, parental control is more powerful and flexible.
    3. If you need something more than basic parental control, you can add extra profiles. Configure each profile with different options and assign devices to profiles.
    4. If you need time control for certain devices, you can add calendars to profiles.
    5. If you need remote access to the router (e.g., when you are away from home), you can enable remote control, which provides you the ability to make changes to the router by logging on pcwrt.com.

    #1678

    tcannon777
    Participant

    I have been using this feature and think it is critical. Unfortunately, it doesn’t consistently work when I try to login remotely. Most of the time, after successfully logging in I get this message “failed to retrieve data..” and cannot access any of the controls/functionality. The only way to resolve this is to reboot the router which is not ideal given the nature of this feature. Any suggestions on how to resolve the issue?

    #1680

    support
    Participant

    @tcannon777 Most likely your pcWRT router is behind NAT. Either it is connected after another router, or your ISP put you behind NAT. For the former, you need to set up port forwarding (described above), or put the pcWRT in the DMZ of the other router. For the latter, you need to contact your ISP.

    #1682

    tcannon777
    Participant

    Ok,my setup is I have my pcWRT router directly connected from my modem. I then connect my pcWRT router to a Linksys router I have setup as an access point to get better wireless coverage. So based on the setup instructions above my pcWRT router isn’t behind another router, but probably doesn’t have a public IP address because the modem is probably determine that, correct? In this case, will simply setting up the Bind port work or do I need to call my ISP and if so what do I need them to do? Thanks!

    #1683

    support
    Participant

    @tcannon777 You can compare the IP addresses to find out whether the pcWRT has a public IP address: log in the pcWRT, on the Status page find the Internet IP address. Then Google “My ip address”. Compare the IP address in search results with that on the Status page. If the IP addresses differ, you are behind NAT. You need your ISP to set up port forwarding for you or take you off NAT.

    #1685

    tcannon777
    Participant

    Ok, I checked the IP address and they are the same, so my pcWRT router does have a public IP address. Given that, how can I resolve the issue? I also noticed that there wasn’t a check for updates button on the system settings page. Thought I might try that as well. Thanks!

    #1686

    support
    Participant

    @tcannon777 Please send these screenshots to [email protected]: Status page, Cloud Settings, System Settings.

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.