Forums

Home Forums Announcements pcWRT firmware v1.22.2 for TORONTO-N Release Notes

pcWRT firmware v1.22.2 for TORONTO-N Release Notes

This topic contains 11 replies, has 2 voices, and was last updated by  support 4 years, 6 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1270

    support
    Participant
    1. Added capability to remote control the router from the Internet.
    2. Added function to rollback firmware to the previous version.
    3. Added ability to whitelist web sites by IP address and IP address blocks. For example, to white list all 255 IP address for Xbox, you can now enter 65.55.42.1/24.
    4. Fixed a bug that blocks port forwarding under certain conditions.
    5. Fixed a bug that blocks Dynamic DNS registration for certain IP addresses.
    6. Various other minor improvements.
    #1271

    support
    Participant

    An additional note: beginning with v1.22.2, passwords stored in configuration backup archives will be encrypted. As a result, if you upgrade to v1.22.2 but then rollback to v1.21.5, you have to reconfigure Dynamic DNS (if you are using it).

    • This reply was modified 4 years, 6 months ago by  support.
    #1304

    nealonious
    Participant

    Router doesn’t appear to be working since I updated this firmware this morning. After the update I can see the network name and when I connect I get “No Internet, secured” on my Windows Wi-Fi menu that shows possible wi-fi networks. I have rebooted the router a couple of times but it doesn’t seem to make a difference. Have tried different devices as well but still no internet connection. On the pcwrt Status page the Status is “down” and shows local time a Sunday March 19 instead of Tuesday MArch 21. The settings I had prior to the update seem to be in place (parental profiles/calendars).

    Any ideas?

    #1306

    support
    Participant

    @nealonious On Status page, Internet should be up, with a valid IP address. On the router, is the WAN light on?

    #1308

    nealonious
    Participant

    On Status page internet is still down, I don’t see an IP address

    Sys light is solid red
    WAN is blinking green
    WLAN is blinking green
    others are off

    #1309

    support
    Participant

    How is the router connected to the internet? Directly to a modem, or through another router or modem/router combo?

    Also, can you check the settings on the Internet page? What does the page show?

    #1310

    nealonious
    Participant

    There is cable from the pcwrt to an Arris modem. At one point several weeks ago I had two routers connected to the modem but it has been 1-2 months since the other router has been turned on or connected to either the modem or pcwrt router.

    The internet page has DHCP client as the protocol, hostname is blank, broadcast flag and custon DNS server boxes are not checked, override MAC address is blank, override MTU blank.

    #1311

    support
    Participant

    Let’s try this:
    1. Reboot the Arris.
    2. After the Arris comes back on, reboot the pcWRT.

    #1312

    nealonious
    Participant

    I reset the Arris and waited 2-3 minutes until all usual lights were lit

    I then reset the pcwrt. There is no change. The same error messages, same light pattern, same internet page settings, status is still down with no IP address

    I could go back to restore faculty default – the modem is only a couple of months old and using screenshots of the current setup reinstall the profiles. The firmware change would not prevent that rolling back to the earlier version, would it?

    #1313

    support
    Participant

    Please try resetting the pcWRT. The procedure below will wipe out all custom settings and restore factory default:
    1. With the pcWRT router powered up, use a pin or pen tip to press and hold the reset button for 10 seconds. Then let go.

    2. Wait for a few seconds. All lights on the router will blink once, and the router will reboot.

    3. After the router comes up, you need to do the initial setup again. Internet should be restored after the initial setup.

    Do not disconnect power during the process.

    Let us know if that works. If you still have trouble, send email to [email protected].

    #1314

    nealonious
    Participant

    Resetting the router seems to have done the trick. It is updated to v1.22.2 and looks like it works fine.

    Thank you for your help.

    p.s. Did you have an announcement of how to use the cloud management feature that I overlooked? I have registered but it isn’t clear how to use this feature. Thanks again

    #1316

    support
    Participant

    Please take a look at this post: http://www.pcwrt.com/forums/topic/how-to-remote-control-the-pcwrt-router/.

    As described at the end of the post, you may need to set up port forwarding on your main router, if the pcWRT router doesn’t have a public IP address.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.